Increased latency across platform

Incident Report for FMX System

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2026 - 11:15 EDT

Update

We're adding additional hardware to increase capacity
Posted Sep 14, 2026 - 10:50 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 14, 2026 - 10:06 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 14, 2026 - 09:59 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 14, 2026 - 09:47 EDT

Investigating

We are currently investigating this issue.
Posted Sep 14, 2026 - 09:17 EDT
This incident affects: Web App, API, and Reporting Dashboards.